This project is read-only.

VCC doesnt find vcc.h

Sep 14, 2016 at 4:14 AM
Edited Sep 14, 2016 at 4:24 AM
I am using vcc from command line. When I run the command "vcc demo.c" , it displays following error:
"Error while running preprocessor: Unable to find the specified file.
Exiting with 3 <1 error(s).>"

the content of demo.c is
#include <vcc.h>

int main()
return 0;

Also, I can see a system variable INCLUDE with value "C:\Program Files\Microsoft Research\Vcc\Headers."

Please help, I am not able to find out the solution.
Feb 10, 2017 at 9:35 AM
I have the same problem.

I can use the C compiler just fine. It finds vcc.h and thus ignores annotations.

But when I try to verify with VCC I get the same error as OP.
Feb 10, 2017 at 2:01 PM
This problem got solved for me when I installed VS2012 and reinstalled VCC. I can nor run VCC fine from command line.

I wanted to avoid this since I've had problems before with multiple versions of Visual Studio installed, oh well. :)
Before I did this I already had VS2010 and VS2012 redistributable packages installed which apparently wasn't enough.

Hope it helps.